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Introducing Your Sun Desktop

Everything on your screen is part of your Sun Desktop, 
which includes many features to make your work easier. 
This introduction presents the basic skills you need to start 
using your Desktop.

As you begin this introduction, rest the mouse on its silvery-
blue pad, with the pad horizontal and the mouse cord 
pointing away from you.

Move the mouse on its pad. Notice how each movement is 
reflected by a black, arrow-shaped pointer on the screen. 

For most of your work you’ll use the left mouse button, 
called the SELECT button. Use the mouse to turn this page: 
move the pointer over the Next Page button above and click 
(press and release) the SELECT button once. 

SELECT
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Viewing This Document

If you have little Sun Desktop experience, you can page 
through this introduction for information. Click the SELECT 
button on the Next Page or Previous Page buttons at the 
top of this window. Or, you can also use the PgUp and PgDn 
keys on the right side of your keyboard to do the paging. 

To backtrack to where you were before your most recent 
move, click the SELECT button on the Go Back button 
above.

If you have some Sun Desktop experience and want to skip 
sections of this introduction, you can jump directly to the 
topic that interests you from the Table of Contents on the 
next page. To jump to the topic you want, double-click the 
SELECT button; that is, press and release it twice, quickly, 
with the pointer on any boxed topic in the Table of Contents.

To return to the Table of Contents from any other page, 
place the pointer over “Table of Contents” at the bottom of 
that page, and double-click the SELECT button.

SELECT
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About Windows

With your Sun Desktop you can run many programs at once, 
each in its own window—its bordered area of the screen. 

This introduction appears in a window on the right of your 
screen. Most of the information here refers to the two other 
windows, which appear at the left of your screen: Console 
(which you’ll use to type commands and read messages), and 
File Manager (which you’ll use to work with your files).

Help Viewer

Console Window

File Manager Window Introduction Window

File Manager:

cmdtool (CONSOLE)  -  /bin/csh

Waste
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Leaving This Introduction

To leave this introduction at any time, place the pointer over 
“Exit,” which appears at the bottom of every page. Then 
double-click the SELECT button; that is, press and release it 
twice, quickly. That takes you to the last page, with 
instructions on how to quit.

Getting Help

As you use your Sun Desktop, you are never far from help. 
Place the pointer on the object you want to know about and 
press the Help key at the lower left of the keyboard. A pop-
up message appears with information about the object you 
selected.

For example, move the pointer to the top bar of the File 
Manager window and place the pointer on either the File or 
the View button. Then press the Help key on the keyboard.

SELECT

SELECT

HelpStop Again

Props Undo

Front Copy

Open Paste

Find Cut

Help
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To clear the message from the screen, click the SELECT 
button once (a single, not double click) on the pushpin in the 
upper left corner of the help message. 

Getting More Help

If you want additional help when viewing a help message, 
click SELECT on More, which appears in some help 
windows. A table of contents from the relevant handbook 
will appear.

You can also go directly from this introduction to the help 
handbooks; double-click SELECT on “More Handbooks” 
below. To reach the handbooks from any other page, first 
double-click on “Exit,” which is at the bottom of each page. 
Then double-click on “Help Handbooks” on the exit page.

For more detailed information about the on-line help system, 
double-click SELECT on the question mark below.

SELECT
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Working with Windows

You can open windows, close each to a small symbol (called 
an “icon”) to save space on the screen, move them around, 
change their size, and scroll through their contents for 
information. 

Closing Windows

To save screen space when you’re not working in a window 
(but want it easily available), you can close the window to an 
icon. To close the File Manager window, for example, click 
SELECT on the boxed arrow in the upper left corner of the 
window. 

SELECT

icon

File Manager:

File View Edit Props
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(Did a window suddenly extend from the top to the bottom of 
the screen? Then you inadvertently double-clicked the 
SELECT button on the top bar of the window frame. To 
return the window to its former size, double-click the 
SELECT button on the top of the frame again.)

Closing a window does not remove it. It just puts the 
window aside in the form of an icon, which reminds you that 
the program in the window is still running. 

The closed File Manager window looks like a small file 
drawer. 

To remove a window from the screen, you must quit that 
window. The final page of this introduction describes how to 
quit.

File Mgr



Table of Contents

 9 of  45

About HelpExit

Opening Windows

To open a window from its icon, double-click the SELECT 
button anywhere on the icon. 

For example, double-click the SELECT button on the File 
Manager icon to reopen the window. 

As you work with your Sun Desktop, you’ll see various icons. 
You can open a window from each.

icon

File Manager:

File View Edit Props

SELECT

Mail Tool Icon Waste Icon
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Moving a Window

To move a window or an icon, first place the pointer on the 
top bar of the window frame, or anywhere on the icon. 

Hold down the SELECT button and slide the mouse on its 
pad to drag an outline of the window or icon to its new 
location. Then release the mouse button.
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For example, move the File Manager window so that part of 
it just overlaps the Console window.

cmdtool (CONSOLE)  -  /bin/csh

File Manager:
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Bringing a Window Forward

To bring a window to the foreground of the screen, place the 
pointer on the top bar of the window frame and click the 
SELECT button.

To bring the Console window forward, for example, click the 
SELECT button once on the top bar of the window. 

If the File Manager window is in the background, move it to 
the foreground before you continue. (If the top bar is 
covered, you can actually click anywhere on the black line 
surrounding a window to move it to the foreground.)

SELECT
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Resizing a Window

You can shrink or enlarge any window that has resize 
corners (small “L”-shapes at each corner). All the windows 
on this screen can be resized, but the help window you called 
up previously, which has no resize corners, cannot be 
resized.

To resize the File Manager window, for example, use the 
SELECT button. First place the pointer on any corner of the 
window; when the pointer is in exactly the right position it 
changes to a circle.

Then, hold down the SELECT button while you slide the 
mouse on its pad to drag the corner. An outline changes size 
as you move the mouse. 

Finally, when the outline is the size you want, release the 
button.
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 Scrolling Through a Window

Often you’ll find that a window holds more information than 
you can see at one time. To view everything the window 
contains, use the scrollbar you’ll find on most windows.

To open a window you can use to practice scrolling, place the 
pointer over the word “Demo” at the left, and double-click 
the SELECT button. (Please wait a moment for the Demo 
window to open.)

Demo

When the Demo window opens, place 
the pointer on the scrollbar’s down 
arrow as shown to the right. Then 
hold down the SELECT button.

Watch how text at the top of the 
window scrolls up and out of view, 
while additional text scrolls into the 
window from the bottom.

Turn to the next page for additional 
information about scrolling.

SELECT
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These are some of the most useful scrollbar controls. Use the 
SELECT button to operate them.

To put the Demo window out of the way temporarily, close it 
to an icon. (Remember, click the SELECT button on the 
arrow in the upper left corner of the window.) The icon looks 
like a keyboard with a sheet of paper; look for it at the 
bottom of the screen .

You’ll see how to quit the Demo at the end of this 
introduction. 

SELECT

Beginning:
Click SELECT

Down one line:
Click SELECT

End: Click SELECT

Up one screen:
Click SELECT

Down one screen:
Click SELECT

Up one line:
Click SELECT

Go to a region of 
the document:
Drag with SELECT
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Menus

Windows, icons—even your background screen—contain 
features you can access through pop-up menus. 

In addition, every button with an arrow has a menu 
associated with it—a button menu. 

Choosing from Menus

To choose a button menu item, place the pointer on the File 
button in File Manager, for example. Press and hold down 
the right mouse button, the MENU button. The menu opens.

Still holding down the MENU button, drag the mouse to 
highlight Create File. Then release the button. 

Notice that you have created a Document icon in the File 
Manager window, labeled “NewDocument.” 

Fi le

MENU

NewDocument



Table of Contents

 17 of  45

About HelpExit

To view a pop-up menu, place the pointer on a blank portion 
of the Workspace, the background space surrounding the 
windows. Then hold down the MENU button. This menu 
appears. It closes when you release the button. 

Submenus

A menu item with a right arrow next to it, as on the 
Workspace menu, indicates a hidden submenu. 

MENU

Workspace

Programs
Utilities
Properties...

Exit...

Help...
Desktop Intro...

MENU
Workspace

Programs
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To see a submenu, hold down the MENU button on the 
Workspace and slide the pointer onto Programs. Continue 
sliding all the way to the right arrow. (This takes a little 
practice. If you select the wrong submenu, slide the pointer 
to the left and try again.) 

To close the menu without making a selection, slide the 
pointer straight up and off the menu, and release the button. 
(If you accidentally open a window, close it to an icon for 
now.)

In this introduction, a submenu name is written in this 
form:  Menu⇒ Submenu. For example, the menu in the 
previous illustration is the Workspace⇒ Programs menu.

Programs

Workspace

Utilities

Properties...

Exit...

File Manager...

Mail Tool...
Calendar Manager...
Clock...

Programs

Command Tool...

Text Editor...

Help...
Desktop Intro...

Calculator...
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Using Menus

Most menus offer a choice of commands or actions you can 
perform on an object (you can print a specific file, for 
example). To apply a menu command to an object:

First, select the object you want to affect.

Then, choose the action you want to apply from the 
appropriate menu.

For example, suppose you want to print a document. (To try 
this, use the NewDocument you created. Although it is 
blank, it can show how selecting a document and printing it 
are related.) 

First, notice what happens if you try to print a document 
without selecting it. 

Place the pointer on the File button in File Manager and 
then press the MENU button. The menu item Print appears 
dimmed, meaning the function is inaccessible until you 
select a document.

MENU Create Folder

Create File

Find...

Open

Print

File
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Now, try selecting the NewDocument and then printing it.

First, select it: click the SELECT button once on the 
NewDocument icon in the File Manager Window. 

The icon becomes highlighted, or darkened, as shown below. 
(You can always unselect something by clicking the SELECT 
button in any blank space surrounding that object.) 

Then open the File menu again (hold down the MENU 
button on File). This time, choose Print from the menu.

If the file you selected contained text, it would be printed.

SELECT

MENU

Create Folder

Create File

Find...

Open

Print

File
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Pinning Menus and Windows

Some menus and windows have a pushpin in the upper left 
corner. When you open a menu or window that contains a 
pushpin, it is usually unpinned. 

An unpinned menu or window will vanish after the first 
action you perform on it. 

If you plan to perform more than one action, pin the menu or 
window. For example, to perform several tasks from the 
Workspace menu, pin the Workspace menu in place.

Hold down the MENU button anywhere in the Workspace 
(the space outside the windows) to open the menu. Then 
slide the pointer over the pushpin and release the MENU 
button. The pin slips into the pinhole.

To dismiss the menu, unpin it; click SELECT on the pin (it’s 
tempting to try to “pull” out the pin by moving the mouse, 
but just click on it).

MENU

Workspace

Programs
Utilities
Properties...

Exit...

Help...
Desktop Intro...
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Using Your Sun Desktop

Now you know the basic information you need to control the 
mouse and use windows. The following pages provide 
directions that go into some more depth. They explain how 
to move and copy text. They also explain how to handle files 
and folders of information that you will be gathering and 
creating with your workstation.

If you would like to take a break now, you have two choices:

You can close this introduction window to its icon, which is 
entitled “More Help.”

Or, you can quit this introduction entirely and return to it 
later. Double-click on “Exit” below. That will take you to the 
final page of this introduction and directions for how to quit. 
You’ll also find instructions there for returning to this 
introduction after you quit.
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Copy, Cut, and Paste Text

Using a Menu to Copy, Cut, and Paste

You can copy and paste, or cut and paste text whenever you 
are writing or editing—in a Text Editor, for example, or 
when composing mail messages. 

If you copy and paste text, the original text remains where it 
is. When you cut and paste text, you move the original text 
to a new location.

In the following steps, you’ll type text and then cut and 
paste a portion of it.
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1. Open a Text Editor window.

Place the pointer anywhere in the Workspace and use the 
MENU button to choose Text Editor... from the 
Workspace⇒ Programs menu.

A text editor window opens. 

2. Move the pointer into the Text Editor window and 
click the SELECT button once.

You are now ready to type.

Programs

Workspace

Utilities

Properties...

Exit...

Mail Tool...
Calendar Manager...
Clock...

Programs

Command Tool...

Help...
Desktop Intro...

Calculator...

File Manager...

Text Editor...

MENU



Table of Contents

 25 of  45

About HelpExit

3. Type the following text in the Text Editor window:

4. Move the pointer to the beginning of the text you 
want to select and click the SELECT button.

5. Move the pointer to the end of the text to select 
and click the ADJUST button.

The text you selected is highlighted.

This is the text to select.  All text  around it is unselected.SELECT

This is the text to select.  All text  around it is unselected.

ADJUST All text  around it is unselected.This is the text to select.
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6. Choose Cut from the Edit menu.

The text disappears and will remain invisible until you 
paste it.

MENU

Again

Undo

Copy

Paste

Cut

Edit
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7. Place the pointer where you want to paste the text 
and click SELECT to set an insert point.

8. Choose Paste from the Edit menu.

The text appears in its new location.

All text  around it is unselected. 

MENU
Again

Undo

Copy

Paste

Cut

Edit

This is the text to select. All text  around it is unselected. 
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Function Keys to Cut, Copy, and Paste 

You can use the left keypad on your keyboard instead of a 
menu to copy, paste, and cut text.   

Use Undo, on the Edit menu or on the function keys, to 
undo a copy, cut, or paste you made by mistake. 

You might want to page back to “Copy, Cut, and Paste Text” 
now, to try the same procedure with the copy and paste 
keys.

Copy L6

Cut L10

Undo L4

Paste L8

Stop Again

Props Undo

Front Copy

Open Paste

Find Cut

Help
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Managing Your Work

As you work, you will create files that contain, for example, 
text, data, or illustrations. To organize these files so you can 
work with them easily, you’ll place them into folders. A 
folder can contain other folders as well as files.

File Manager offers a visual way to:

• Organize your files

• Search for files or folders

• Move or copy files

• Start a program from a file

The following pages give an overview of some things File 
Manager can do for you. For more details, see the 
OpenWindows User’s Guide and DeskSet Reference Guide for 
OpenWindows.
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Starting File Manager

If File Manager does not appear on your screen, choose File 
Manager... from the Workspace⇒ Programs menu. (If 
File Manager appears as its file drawer-shaped icon,  double 
click SELECT to open it.) 

MENU

Programs

Workspace

Utilities

Properties...

Exit...

Mail Tool...
Calendar Manager...
Clock...

Programs

Command Tool...

Text Editor...

Help...
Desktop Intro...

Calculator...

File Manager...
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Creating New Documents and Folders

1. In the File Manager window, choose Create File 
from the File menu.

An icon for the new document appears, named 
NewDocument (or New Document.1, if you already created 
a new document). The name is underlined to show that 
you can give it a new name.

MENU
Create Folder

Create File

Find...

Open

Print

File

NewDocument
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2. Select the name (NewDocument or 
NewDocument.1).

Place the pointer on the name, then click SELECT once. 
The name is highlighted.

3. Type the name Myfile and press Return.

The document icon appears with the name Myfile.

SELECT

NewDocument

Myfile



Table of Contents

 33 of  45

About HelpExit

4. Choose Create Folder from the File menu.

The new folder appears, underlined to show that you can 
give it a new name:

MENU Create Folder

Create File

Find...

Open

Print

File

Myfile NewFolder
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5.  Click SELECT on the name NewFolder to select it.

6. Type the name Myfolder and press Return.

The name Myfolder appears below the folder icon.

SELECT

Myfile NewFolder

Myfile Myfolder
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Placing a File into a Folder

You can put a file into a folder by dragging the file onto the 
folder icon. 

1. Select Myfile.

Place the pointer on the icon for Myfile and click SELECT 
to select it.

2. Place Myfile in Myfolder.

Place the pointer on Myfile and hold down the SELECT 
button. Then drag Myfile on top of the Myfolder icon and 
release the SELECT button.

This puts the file into the folder.

A selected file looks like this.

SELECT

Myfolder
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To see the contents of Myfolder, open the folder by double-
clicking SELECT on its icon.

SELECT Myfolder
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Opening a File and Starting a Program

Each file you view in File Manager is created by a program. 
You can open the file and start the program at the same 
time, by double-clicking SELECT on the file icon.

Double-click SELECT on the Myfile icon to start Text Editor.

At this point, since you won’t be working in the Text Editor 
window, you should quit it, as described on the next page.

Text Editor:File Manager:
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To quit, first point to the top bar of the Text Editor window.

Then press the MENU mouse button and drag the mouse to 
choose Quit from the Window menu.

After you release the mouse button, notice that Myfile is still 
in the File Manager window. Quit did not delete the file. It 
just removed it from your Workspace.

Text Editor:

MENU

Window

Close

Full Size

Back
Refresh

Quit

Properties

Move
Resize
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Deleting a File

In File Manager, you can delete a file by sending it to the 
Wastebasket.

1. Use the SELECT button to select Myfile. 

Point to the icon for Myfile and click SELECT.

2. Open the Edit menu, drag the pointer to Delete, 
and release the MENU button.

This method of deleting a file keeps the file in the 
wastebasket until you quit File Manager, just in case you 
want to retrieve the file.

SELECT

MENU

Waste
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Viewing Your Folders

The top of the File Manager window shows you where you 
are in the file system. The illustrations shown here are just 
an example. Your File Manager window will look different.

The path shows which folder is open and where that folder is 
located. In the example below, “bay” is the open folder in 
this path. It is in “otter,” which is in “ocean,” and so on. 

File Manager:

/ home ocean otter bay
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Choose Show Tree from the View menu to display the tree, 
which can show all the folders, not just the open one. 

Choose Show Path from the View menu to return to a 
display of the path.

boating

book 3 book 4book 2book 1

otter

bay

lagoon supplies

S-tea
mweath

er
banqu
ets

freight
medic
al

holida
ys

home

ocean

File Manager:
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Utilities to Help You Work

Utilities provide a number of services that will be helpful in 
your day-to-day work. You can find the Utilities menu on 
the Workspace pop-up menu. 

Workspace

Programs
Utilities
Properties...

Exit...

Help...
Desktop Intro...

Refresh

Reset Input

Function Keys

Window Controls

Save Workspace

Lock Screen

Console...

Reset Input
Clears up some kinds of text 
input problems. 
Example: letters you type are 
garbled on the screen.

Function Keys
Displays keys F1-F12 on the 
screen. You can select these 
with the mouse.

Window Controls
Displays options you can use 
on one or more selected win-
dows.

Save Workspace
Saves the current arrange-
ment of windows and icons.

Lock Screen
Locks the screen for security 
and displays a pattern. Use 
your password to unlock it.

Console...
Pops up a Console 
window for system 
commands.

Refresh
Cleans up display 
problems.
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Starting Some Sample Programs

Shown below is a program sampler. Double-click SELECT 
on the icon for the program you want to start.

You can also start these programs from the 
Workspace⇒ Programs menu. Some, especially Calendar 
Manager, take awhile to start.

See the OpenWindows User’s Guide for more details about 
these programs.

Caution: Don’t run two versions of Calendar Manager or 
Mail Tool! That might lead to complications.

SELECT

PerfmeterJanuaryClock

Mail Tool CalculatorSnapshot
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Sound and Your Workstation

Your workstation is an audio, as well as a visual, machine. 
For descriptions of how you can work with sound on your 
workstation, see the OpenWindows User’s Guide and 
DeskSet Reference Guide for OpenWindows.

For a quick demonstration of sound, double-click SELECT 
on the sound you want to hear.

SELECT

Train

Music Laugh

Rooster

Cuckoo 

Drip
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For Additional Information 

To learn more about your Sun Desktop, please see the 
reference manuals, OpenWindows User’s Guide and DeskSet 
Reference Guide for OpenWindows.

You can always return to this introduction by choosing 
Desktop Intro from the Workspace menu.

Quitting the Demo Window

Before you leave this introduction, quit the Scrollbar Demo 
window. Place the pointer on the Demo icon (or on the top 
bar of the window frame if it is still open). Then press 
MENU, drag the pointer to Quit, and release the button.

After You Exit

To prevent this introduction from coming up again 
automatically when you restart your workstation, after you 
exit (see How to Exit, below) select Save Workspace from 
the Workspace⇒ Utilities menu.

How to Exit

Place the pointer on the top bar of the window containing 
this introduction. Then hold down the MENU button, drag 
the pointer to Quit, and release the button.

MENU


